summaryrefslogtreecommitdiff
path: root/modules/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/emacs.nix')
-rw-r--r--modules/emacs.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/emacs.nix b/modules/emacs.nix
new file mode 100644
index 0000000..8a59c9b
--- /dev/null
+++ b/modules/emacs.nix
@@ -0,0 +1,19 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.emacs;
+in
+{
+ config = mkIf cfg.enable {
+ nixfiles.modules.common.xdg.defaultApplications.emacs = [
+ "application/atom+xml"
+ "application/json"
+ "application/rss+xml"
+ "application/schema+json"
+ "application/xhtml+xml"
+ "application/xml"
+ "text/csv"
+ "text/plain"
+ ];
+ };
+}