summaryrefslogtreecommitdiff
path: root/modules/nixos/bluetooth.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/bluetooth.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/bluetooth.nix')
-rw-r--r--modules/nixos/bluetooth.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/nixos/bluetooth.nix b/modules/nixos/bluetooth.nix
new file mode 100644
index 0000000..8347361
--- /dev/null
+++ b/modules/nixos/bluetooth.nix
@@ -0,0 +1,28 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.bluetooth;
+in {
+ options.nixfiles.modules.bluetooth.enable =
+ mkEnableOption "Bluetooth support";
+
+ config = mkIf cfg.enable {
+ hardware.bluetooth = {
+ enable = true;
+ settings.General.FastConnectable = true;
+ };
+
+ environment = {
+ etc."bluetooth/input.conf".text = generators.toINI {} {
+ General = {
+ IdleTimeout = 15;
+ UserspaceHID = true;
+ };
+ };
+ };
+ };
+}