summaryrefslogtreecommitdiff
path: root/modules/nixos/bluetooth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/bluetooth.nix')
-rw-r--r--modules/nixos/bluetooth.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/nixos/bluetooth.nix b/modules/nixos/bluetooth.nix
new file mode 100644
index 0000000..8347361
--- /dev/null
+++ b/modules/nixos/bluetooth.nix
@@ -0,0 +1,28 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.bluetooth;
+in {
+ options.nixfiles.modules.bluetooth.enable =
+ mkEnableOption "Bluetooth support";
+
+ config = mkIf cfg.enable {
+ hardware.bluetooth = {
+ enable = true;
+ settings.General.FastConnectable = true;
+ };
+
+ environment = {
+ etc."bluetooth/input.conf".text = generators.toINI {} {
+ General = {
+ IdleTimeout = 15;
+ UserspaceHID = true;
+ };
+ };
+ };
+ };
+}