summaryrefslogtreecommitdiff
path: root/modules/nixos/common/locale.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-12-03 02:52:28 +0300
committerAzat Bahawi <azat@bahawi.net>2023-12-03 02:52:28 +0300
commitcec9f7acd5e5e365563212c5144394f71dd90b27 (patch)
tree667b308a7241ab2e8f3fa4e2b53cc7888e876c68 /modules/nixos/common/locale.nix
parent3c5d840e8d92aee25aa411fc2ab7f8881cfdfede (diff)
2023-12-03
Diffstat (limited to 'modules/nixos/common/locale.nix')
-rw-r--r--modules/nixos/common/locale.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/nixos/common/locale.nix b/modules/nixos/common/locale.nix
index 09e0686..9d73af4 100644
--- a/modules/nixos/common/locale.nix
+++ b/modules/nixos/common/locale.nix
@@ -23,6 +23,31 @@ with lib; {
};
};
+ hm.xdg.configFile."fcitx5/profile".text = generators.toINI {} {
+ "Groups/0" = {
+ Name = "Default";
+ DefaultIM = "mozc";
+ "Default Layout" = "us";
+ };
+
+ "Groups/0/Items/0" = {
+ Name = "keyboard-us";
+ Layout = "";
+ };
+
+ "Groups/0/Items/1" = {
+ Name = "mozc";
+ Layout = "us";
+ };
+
+ "Groups/0/Items/2" = {
+ Name = "keyboard-ru-phonetic";
+ Layout = "";
+ };
+
+ GroupOrder."0" = "Default";
+ };
+
services.xserver = {
layout = "us";
xkbOptions = concatStringsSep "," [