summaryrefslogtreecommitdiff
path: root/modules/nixos/common/locale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/locale.nix')
-rw-r--r--modules/nixos/common/locale.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/nixos/common/locale.nix b/modules/nixos/common/locale.nix
index 09e0686..9d73af4 100644
--- a/modules/nixos/common/locale.nix
+++ b/modules/nixos/common/locale.nix
@@ -23,6 +23,31 @@ with lib; {
};
};
+ hm.xdg.configFile."fcitx5/profile".text = generators.toINI {} {
+ "Groups/0" = {
+ Name = "Default";
+ DefaultIM = "mozc";
+ "Default Layout" = "us";
+ };
+
+ "Groups/0/Items/0" = {
+ Name = "keyboard-us";
+ Layout = "";
+ };
+
+ "Groups/0/Items/1" = {
+ Name = "mozc";
+ Layout = "us";
+ };
+
+ "Groups/0/Items/2" = {
+ Name = "keyboard-ru-phonetic";
+ Layout = "";
+ };
+
+ GroupOrder."0" = "Default";
+ };
+
services.xserver = {
layout = "us";
xkbOptions = concatStringsSep "," [