summaryrefslogtreecommitdiff
path: root/modules/nixos/endlessh.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/endlessh.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/endlessh.nix')
-rw-r--r--modules/nixos/endlessh.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/nixos/endlessh.nix b/modules/nixos/endlessh.nix
new file mode 100644
index 0000000..67789fd
--- /dev/null
+++ b/modules/nixos/endlessh.nix
@@ -0,0 +1,24 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.endlessh;
+in {
+ options.nixfiles.modules.endlessh.enable = mkEnableOption "endlessh";
+
+ config = let
+ port = 22;
+ in
+ mkIf cfg.enable {
+ services.endlessh = {
+ enable = true;
+ inherit port;
+ extraOptions = ["-v" "-4"];
+ };
+
+ networking.firewall.allowedTCPPorts = [port];
+ };
+}