summaryrefslogtreecommitdiff
path: root/modules/nixos/endlessh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/endlessh.nix')
-rw-r--r--modules/nixos/endlessh.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/nixos/endlessh.nix b/modules/nixos/endlessh.nix
new file mode 100644
index 0000000..67789fd
--- /dev/null
+++ b/modules/nixos/endlessh.nix
@@ -0,0 +1,24 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.endlessh;
+in {
+ options.nixfiles.modules.endlessh.enable = mkEnableOption "endlessh";
+
+ config = let
+ port = 22;
+ in
+ mkIf cfg.enable {
+ services.endlessh = {
+ enable = true;
+ inherit port;
+ extraOptions = ["-v" "-4"];
+ };
+
+ networking.firewall.allowedTCPPorts = [port];
+ };
+}