summaryrefslogtreecommitdiff
path: root/modules/nixos/games/gamemode.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/nixos/games/gamemode.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/nixos/games/gamemode.nix')
-rw-r--r--modules/nixos/games/gamemode.nix19
1 files changed, 7 insertions, 12 deletions
diff --git a/modules/nixos/games/gamemode.nix b/modules/nixos/games/gamemode.nix
index 193a764..eb485f8 100644
--- a/modules/nixos/games/gamemode.nix
+++ b/modules/nixos/games/gamemode.nix
@@ -1,18 +1,13 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.games.gamemode;
-in {
- options.nixfiles.modules.games.gamemode.enable =
- mkEnableOption "Feral GameMode";
+in
+{
+ options.nixfiles.modules.games.gamemode.enable = mkEnableOption "Feral GameMode";
config = mkIf cfg.enable {
- hm.xdg.configFile."gamemode.ini".text = generators.toINI {} {
- general.softrealtime = "auto";
- };
+ hm.xdg.configFile."gamemode.ini".text = generators.toINI { } { general.softrealtime = "auto"; };
programs.gamemode.enable = true;
};