summaryrefslogtreecommitdiff
path: root/modules/nixos/games/gamemode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/gamemode.nix')
-rw-r--r--modules/nixos/games/gamemode.nix19
1 files changed, 7 insertions, 12 deletions
diff --git a/modules/nixos/games/gamemode.nix b/modules/nixos/games/gamemode.nix
index 193a764..eb485f8 100644
--- a/modules/nixos/games/gamemode.nix
+++ b/modules/nixos/games/gamemode.nix
@@ -1,18 +1,13 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.games.gamemode;
-in {
- options.nixfiles.modules.games.gamemode.enable =
- mkEnableOption "Feral GameMode";
+in
+{
+ options.nixfiles.modules.games.gamemode.enable = mkEnableOption "Feral GameMode";
config = mkIf cfg.enable {
- hm.xdg.configFile."gamemode.ini".text = generators.toINI {} {
- general.softrealtime = "auto";
- };
+ hm.xdg.configFile."gamemode.ini".text = generators.toINI { } { general.softrealtime = "auto"; };
programs.gamemode.enable = true;
};