summaryrefslogtreecommitdiff
path: root/modules/nixos/games/steam.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-08 21:30:37 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-08 21:30:37 +0300
commit04be52d7b75eb62203a3af8d85e36e3584123f90 (patch)
tree5ad22924998c10c45834eadae6c0498a3ac4be1b /modules/nixos/games/steam.nix
parent037ef27243eab47d6e1c29f231c248dc2aa4966e (diff)
2024-03-08
Diffstat (limited to 'modules/nixos/games/steam.nix')
-rw-r--r--modules/nixos/games/steam.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/nixos/games/steam.nix b/modules/nixos/games/steam.nix
index 8dfa72c..c81d344 100644
--- a/modules/nixos/games/steam.nix
+++ b/modules/nixos/games/steam.nix
@@ -17,9 +17,15 @@ in {
games = {
enable32BitSupport = true;
gamemode.enable = true;
+ mangohud.enable = true;
};
};
- hm.home.packages = with pkgs; [steam];
+ hm.home.packages = with pkgs; [
+ (steam.override {extraEnv.MANGOHUD = 1;})
+ protontricks
+ ];
+
+ hardware.steam-hardware.enable = true;
};
}