summaryrefslogtreecommitdiff
path: root/modules/nixos/games/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/steam.nix')
-rw-r--r--modules/nixos/games/steam.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/nixos/games/steam.nix b/modules/nixos/games/steam.nix
index 8dfa72c..c81d344 100644
--- a/modules/nixos/games/steam.nix
+++ b/modules/nixos/games/steam.nix
@@ -17,9 +17,15 @@ in {
games = {
enable32BitSupport = true;
gamemode.enable = true;
+ mangohud.enable = true;
};
};
- hm.home.packages = with pkgs; [steam];
+ hm.home.packages = with pkgs; [
+ (steam.override {extraEnv.MANGOHUD = 1;})
+ protontricks
+ ];
+
+ hardware.steam-hardware.enable = true;
};
}