summaryrefslogtreecommitdiff
path: root/modules/nixos/postgresql.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-19 21:35:36 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-19 21:35:36 +0300
commit9e3f4268c87b0d1a64e9429ea173252a5f774ec5 (patch)
tree12896bfa12d7175a22c1e8091cfcc785112df12b /modules/nixos/postgresql.nix
parent91fb4f28ef5d87e8bcf7749928d30ba4a9cbbd34 (diff)
2023-02-19
Diffstat (limited to 'modules/nixos/postgresql.nix')
-rw-r--r--modules/nixos/postgresql.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/nixos/postgresql.nix b/modules/nixos/postgresql.nix
index df05e7e..79515e8 100644
--- a/modules/nixos/postgresql.nix
+++ b/modules/nixos/postgresql.nix
@@ -43,6 +43,9 @@ in {
inherit (cfg) package;
+ # In hindsight, it was a poor choice to use ICU as a locale provider.
+ # Now each time ICU version is bumped, I need to carefully upgrade each
+ # database to match the version.
initdbArgs = [
"--encoding=UTF8"
"--locale-provider=icu"
@@ -52,6 +55,9 @@ in {
"--lc-ctype=C"
];
+ # This crutch is here because some services cannot work via a UNIX
+ # socket connection and I can't be bothered to configure proper
+ # authentication.
authentication = ''
local all all trust
'';