summaryrefslogtreecommitdiff
path: root/modules/nixos/postgresql.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/postgresql.nix')
-rw-r--r--modules/nixos/postgresql.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/nixos/postgresql.nix b/modules/nixos/postgresql.nix
index df05e7e..79515e8 100644
--- a/modules/nixos/postgresql.nix
+++ b/modules/nixos/postgresql.nix
@@ -43,6 +43,9 @@ in {
inherit (cfg) package;
+ # In hindsight, it was a poor choice to use ICU as a locale provider.
+ # Now each time ICU version is bumped, I need to carefully upgrade each
+ # database to match the version.
initdbArgs = [
"--encoding=UTF8"
"--locale-provider=icu"
@@ -52,6 +55,9 @@ in {
"--lc-ctype=C"
];
+ # This crutch is here because some services cannot work via a UNIX
+ # socket connection and I can't be bothered to configure proper
+ # authentication.
authentication = ''
local all all trust
'';