summaryrefslogtreecommitdiff
path: root/modules/profiles/headful.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-04 16:11:40 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-04 16:11:40 +0300
commit3cd3233f7eaf2a8a715d587820d6d4577a24d958 (patch)
treef87bd583c383b8ac3496229ab6f1d3a00a2253a0 /modules/profiles/headful.nix
parent3c61dc9cc35ed201877d81b1b7ad848f1ac9855e (diff)
2024-05-04
Diffstat (limited to 'modules/profiles/headful.nix')
-rw-r--r--modules/profiles/headful.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/modules/profiles/headful.nix b/modules/profiles/headful.nix
index 6e58dae..7060e49 100644
--- a/modules/profiles/headful.nix
+++ b/modules/profiles/headful.nix
@@ -1,5 +1,6 @@
{
config,
+ inputs,
lib,
pkgs,
this,
@@ -40,6 +41,8 @@ in
};
hm = {
+ imports = [ inputs.nix-index-database.hmModules.nix-index ];
+
home = {
file.".digrc".text = ''
+answer
@@ -62,7 +65,11 @@ in
];
};
- programs.bash.shellAliases.open = "xdg-open";
+ programs = {
+ bash.shellAliases.open = "xdg-open";
+
+ nix-index-database.comma.enable = true;
+ };
};
boot = {
@@ -113,6 +120,7 @@ in
lm_sensors
socat
tcpdump
+ usbutils
];
my.extraGroups = [