summaryrefslogtreecommitdiff
path: root/modules/profiles/headful.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/profiles/headful.nix')
-rw-r--r--modules/profiles/headful.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/modules/profiles/headful.nix b/modules/profiles/headful.nix
index 6e58dae..7060e49 100644
--- a/modules/profiles/headful.nix
+++ b/modules/profiles/headful.nix
@@ -1,5 +1,6 @@
{
config,
+ inputs,
lib,
pkgs,
this,
@@ -40,6 +41,8 @@ in
};
hm = {
+ imports = [ inputs.nix-index-database.hmModules.nix-index ];
+
home = {
file.".digrc".text = ''
+answer
@@ -62,7 +65,11 @@ in
];
};
- programs.bash.shellAliases.open = "xdg-open";
+ programs = {
+ bash.shellAliases.open = "xdg-open";
+
+ nix-index-database.comma.enable = true;
+ };
};
boot = {
@@ -113,6 +120,7 @@ in
lm_sensors
socat
tcpdump
+ usbutils
];
my.extraGroups = [