summaryrefslogtreecommitdiff
path: root/topology.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-02 03:17:48 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-02 03:17:48 +0300
commit9b3ebd974bde5c8ebe1f8c8f049f7ee2c6462655 (patch)
tree408194f6f761872df938888ebc4ce46244168618 /topology.nix
parent9a20404924fda2587ce4f9769f75369799f34643 (diff)
2024-05-02
Diffstat (limited to 'topology.nix')
-rw-r--r--topology.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/topology.nix b/topology.nix
index 8830f12..a9d1501 100644
--- a/topology.nix
+++ b/topology.nix
@@ -1,8 +1,22 @@
-inputs: self: pkgs:
+{
+ inputs,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
import inputs.nix-topology {
inherit pkgs;
modules = [
- { inherit (self) nixosConfigurations; }
- (_: { })
+ {
+ nixosConfigurations = filterAttrs (
+ n: _: !(hasPrefix "test" n) && !(hasPrefix "iso" n)
+ ) inputs.self.nixosConfigurations;
+ }
+ (_: {
+ nodes = mapAttrs (_: v: { inherit (v) deviceIcon; }) (
+ filterAttrs (_: v: !v.isOther) my.configurations
+ );
+ })
];
}