summaryrefslogtreecommitdiff
path: root/topology.nix
diff options
context:
space:
mode:
Diffstat (limited to 'topology.nix')
-rw-r--r--topology.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/topology.nix b/topology.nix
index 8830f12..a9d1501 100644
--- a/topology.nix
+++ b/topology.nix
@@ -1,8 +1,22 @@
-inputs: self: pkgs:
+{
+ inputs,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
import inputs.nix-topology {
inherit pkgs;
modules = [
- { inherit (self) nixosConfigurations; }
- (_: { })
+ {
+ nixosConfigurations = filterAttrs (
+ n: _: !(hasPrefix "test" n) && !(hasPrefix "iso" n)
+ ) inputs.self.nixosConfigurations;
+ }
+ (_: {
+ nodes = mapAttrs (_: v: { inherit (v) deviceIcon; }) (
+ filterAttrs (_: v: !v.isOther) my.configurations
+ );
+ })
];
}