summaryrefslogtreecommitdiff
path: root/modules/nixos/plausible.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/plausible.nix')
-rw-r--r--modules/nixos/plausible.nix19
1 files changed, 3 insertions, 16 deletions
diff --git a/modules/nixos/plausible.nix b/modules/nixos/plausible.nix
index 856b318..6553462 100644
--- a/modules/nixos/plausible.nix
+++ b/modules/nixos/plausible.nix
@@ -2,18 +2,11 @@
config,
inputs,
lib,
- pkgsPr,
...
}:
with lib; let
cfg = config.nixfiles.modules.plausible;
in {
- disabledModules = ["services/web-apps/plausible.nix"];
- imports = [
- # TODO Wait for https://github.com/NixOS/nixpkgs/pull/253687
- ./plausible-nixpkgs-override.nix
- ];
-
options.nixfiles.modules.plausible = {
enable = mkEnableOption "Plausible Analytics";
@@ -57,12 +50,9 @@ in {
nginx = {
enable = true;
upstreams.plausible.servers."127.0.0.1:${toString cfg.port}" = {};
- virtualHosts.${cfg.domain} = {
- locations."/" = {
- proxyPass = "http://plausible";
- proxyWebsockets = true;
- };
- extraConfig = nginxInternalOnly;
+ virtualHosts.${cfg.domain}.locations."/" = {
+ proxyPass = "http://plausible";
+ proxyWebsockets = true;
};
};
postgresql = {
@@ -90,9 +80,6 @@ in {
services.plausible = {
enable = true;
- # TODO Wait for https://github.com/NixOS/nixpkgs/pull/253687
- package = (pkgsPr 253687 "sha256-36nXNVmZDgf//MrM6/VC7W4Vm013tJ6MlXvYQElhRRw=").plausible;
-
adminUser = {
name = "admin";
email = "admin@${my.domain.shire}";